left alt release not working anymore

Comments specifically about gestures and mouse actions - on any FW product.

Moderator: The00Dustin

left alt release not working anymore

Postby lee griggs » 04 Apr 2006, 10:32

Hello,

Ive just got a new machine and one of my gestures doesnt seem to be working properly as it does with my home machine.

The gesture is:

Search & Middle Click/Drag on right hand 'release' which I have set to 'Left Alt' with a duration of 50.

This enables me to orbit in maya after panning with 2 fingers and thumb dragging.

Now the 'Left alt' on release doesnt work on my work machine and yet does at home.

If anyone has any idea as to why this isnt working I would appreciate it.

cheers,
lee :)
lee griggs
Smarty Pants
 
Posts: 81
Joined: 21 Aug 2005, 20:49

Postby ivanw » 04 Apr 2006, 10:55

I would suggest getting the scancode sequence received by the application.

On windows you can do that with mskey.exe:
User avatar
ivanw
Zealot
 
Posts: 390
Joined: 29 Jul 2005, 12:32
Location: Paris, France

Postby lee griggs » 05 Apr 2006, 10:21

wow, thanks Ivan I never knew this program existed! :D

I will have a look into it.

any chance you could you give me any hints on how I can do the following?:

'I would suggest getting the scancode sequence received by the application'

how would this help my particular problem?

thanks again for your help,
lee :D
lee griggs
Smarty Pants
 
Posts: 81
Joined: 21 Aug 2005, 20:49

Re: left alt release not working anymore

Postby ivanw » 05 Apr 2006, 13:26

lee griggs wrote:Ive just got a new machine and one of my gestures doesnt seem to be working properly as it does with my home machine.
I would look for some difference in the environmental configuration.. OS, Service Pack, driver, language, keyboard preference, ...
Search & Middle Click/Drag on right hand 'release' which I have set to 'Left Alt' with a duration of 50.
I don't use Maya, meaning that I don't know what to look for that could explain the problem.
This enables me to orbit in Maya after panning with 2 fingers and thumb dragging.
We may have a mixture of keystrokes, mouse and modifier aspects to consider here...
Now the 'Left alt' on release doesn't work on my work machine and yet does at home.
This means that the TS and its customization are not where to look for a solution. This is definitely a contextual problem.
There is some difference somewhere between the two machines. That can bee either in the hardware the driver or the software.
This is all guesswork, as much as I can see from where I stand... :wink:

Let us know what you get after checking...

Some more aggressive measure to handle the problem could rely on using AutoHotkey.

This scripting tool can transform any key-press or mouse-click into any sequence of input events you choose. I am currently finalizing a transposition of all the embedded pad chordings on a standard keyboard thru Capslock Tab and tilde used as supplementary modifier keys (sort of chording). And believe it or not, it looks like is it a working :idea: ...
User avatar
ivanw
Zealot
 
Posts: 390
Joined: 29 Jul 2005, 12:32
Location: Paris, France

duration (ms)

Postby lee griggs » 16 Apr 2006, 15:19

Hi Ivan,

I tried mskey.exe and it doesnt seem to be displaying the left Alt release on lift at all!

It seems to be treating the gesture as a simple alt rather than an alt WITH DURATION. I can see this clearly when I let go as the windows menu at the top is activating (which is what normally happens when you TAP alt).

However it is the DURATION that isnt being recognised like it used to be.

The same thing is happening on my home machine (since I reformatted) so it cannot be a machine specific thing.

KEY HOLD for left alt on release seems to work. Unfortunately it stays like that, which I dont want.

Does this shed any light?
cheers,
lee
lee griggs
Smarty Pants
 
Posts: 81
Joined: 21 Aug 2005, 20:49

Postby ivanw » 16 Apr 2006, 17:36

He Lee.

I have tried your customization on my system running Windows XP Pro SP2 and it looks like it is working exactly as you expected.

I have selected the maximum possible delay of 125ms to be able to make the difference in mskey.exe between a tap on the Left Alt key and the generated LeftAlt keystroke for from the gesture:

Maybe you can pinpoint a difference with your configuration and mine from this screenshot...
Image

If it is not the case, you can post your settings from the Global Feature Selector tabs of the editor on http://img223.imageshack.us/...
User avatar
ivanw
Zealot
 
Posts: 390
Joined: 29 Jul 2005, 12:32
Location: Paris, France

:oops:

Postby lee griggs » 12 May 2006, 17:18

Ivan, I feel like such an idiot. :oops:

I forgot to switch on 'sticky keys' on my new machine.

again sorry to waste your valuable expertise/time,
lee
lee griggs
Smarty Pants
 
Posts: 81
Joined: 21 Aug 2005, 20:49

Postby lee griggs » 12 May 2006, 17:20

I like your sleek black interface btw. How did you get that look - is it really windows?
lee griggs
Smarty Pants
 
Posts: 81
Joined: 21 Aug 2005, 20:49

Postby ivanw » 12 May 2006, 18:27

I like your sleek black interface btw. How did you get that look - is it really windows?


Yes, it is Windows!

You can get Vista XP here:

Image

I've tried many skins from this great Phtoshop lovers site... many icons to download from there too!

... 8) more nice tools:


:wink:
[URL=http://img99.imageshack.us/my.php?image=capture0tl.png]BTW here is my sleek desktop:
Image[/URL]
User avatar
ivanw
Zealot
 
Posts: 390
Joined: 29 Jul 2005, 12:32
Location: Paris, France


Return to Mousing and Gesturing

Who is online

Users browsing this forum: No registered users and 0 guests

cron