Programmers Pad

Comments specifically about typing on TS keyboards, and about key layouts.

Moderator: The00Dustin

Post Reply
Max
Regular
Posts: 47
Joined: 23 May 2005, 08:43
Location: Bucks, UK
Contact:

Programmers Pad

Post by Max »

Hi,

I am trying to make my two Touchstreams behave the same way. One is a DVORAK model and the other is a QWERTZ. It appears that sending the two keyboards the same file does not result in the same behaviour. I have had to swap the Y and Z keys, but can't seem able to get the punct pad to work on my QWERTZ. Any ideas?

Max

PS I have never managed to get the \| key to work on either keyboard. Anyone else have this problem?

nomaded
Smarty Pants
Posts: 131
Joined: 27 Apr 2005, 04:11
Location: MA
Contact:

Post by nomaded »

I believe the xml file that you upload is more like a differential file from the keyboard's default.

I would suggest that it would be easiest to just set up both keyboards manually via the MyGesture Editor.

And my \| seems to work fine on all my keyboards, but then again, they are all QWERTY keyboards that are configured to output Dvorak.
@nomaded

TouchStream Mini - February 26, 2002 - Sold
TouchStream Stealth - March 18, 2002 - Windows 7 Ultimate (home)
TouchStream MacNTouch (white) - July 23, 2003 - Retired
TouchStream LP - March 31, 2004 - In storage
TouchStream MacNTouch (silver) - December 1, 2004 - In storage
Stenovations Digitouch (dvorak) - 2007 - Windows 7 Ultimate (work)
Stenovations Digitouch (dvorak) - 2007 - In storage

User avatar
TorbenGB
Site Admin
Posts: 536
Joined: 26 Apr 2005, 00:07
Location: Vienna, Austria
Contact:

Re: Programmers Pad

Post by TorbenGB »

Max wrote:PS I have never managed to get the \| key to work on either keyboard. Anyone else have this problem?
Are you aware that this key exists twice? One is called "\|" and the other is called "NonUS \|" and the latter is probably what you're looking for?
TorbenGB - webmaster & forum admin

Max
Regular
Posts: 47
Joined: 23 May 2005, 08:43
Location: Bucks, UK
Contact:

Post by Max »

I have tried that option, but whichever key I use always comes out with #~, not \|.

Correction, that works.

Max
Regular
Posts: 47
Joined: 23 May 2005, 08:43
Location: Bucks, UK
Contact:

Post by Max »

I have had another go at getting the programmers' pad working on my QWERTZ touchstream. I have selected the option but it doesn't appear to work. Any ideas? Is there something that could be overriding the setting?

Max

antifuchs
Hang-around
Posts: 3
Joined: 03 Dec 2005, 16:45
Contact:

same problem here

Post by antifuchs »

I have a QWERTZ fw keyboard (firmware 1.6), with a similar problem, and this is what I found out:

the programmer's pad worked when I bought it, but I wanted to use the "stretch" gesture for altgr like US fw keyboards use, and use the top and bottom row for alt and control.

Turning on US mode activated the control/alt row gestures, but the keyboard doesn't react when using the AltGR (right alt) gesture other than send the right alt key code over the bus. Although I activated the programmer's pad, it doesn't seem to register in the touchstream.

While I was experimenting with it, I once got the AltGR gesture exclusively working on the left side, that is, it never sent the Alt keycode, but activated the programer's pad.

One thing I'll try now is to re-set it and feed it my library again. Maybe that'll teach it some sense (-:

Max
Regular
Posts: 47
Joined: 23 May 2005, 08:43
Location: Bucks, UK
Contact:

Re: same problem here

Post by Max »

Thank you for the interesting observations. It does indeed look like some settings may be overriding the programmers' pad setting. Perhaps it is time to do some more playing around. The only problem is that my home PC doesn't seem to like reprogramming the Touchstream. I'll see how I go.
antifuchs wrote:I have a QWERTZ fw keyboard (firmware 1.6), with a similar problem, and this is what I found out:

the programmer's pad worked when I bought it, but I wanted to use the "stretch" gesture for altgr like US fw keyboards use, and use the top and bottom row for alt and control.

Turning on US mode activated the control/alt row gestures, but the keyboard doesn't react when using the AltGR (right alt) gesture other than send the right alt key code over the bus. Although I activated the programmer's pad, it doesn't seem to register in the touchstream.

While I was experimenting with it, I once got the AltGR gesture exclusively working on the left side, that is, it never sent the Alt keycode, but activated the programer's pad.

One thing I'll try now is to re-set it and feed it my library again. Maybe that'll teach it some sense (-:

Max
Regular
Posts: 47
Joined: 23 May 2005, 08:43
Location: Bucks, UK
Contact:

Re: same problem here

Post by Max »

Update, still can't get the programmers' pad to work on the QWERTZ model. I have tried playing with various options. Perhaps I need to reset it and start again.

Out of interest, if anyone has a DVORAK touchstream who wants to swap for a QWERTZ, I may be interested. I'm not doing too well switching between the two.
Max wrote:Thank you for the interesting observations. It does indeed look like some settings may be overriding the programmers' pad setting. Perhaps it is time to do some more playing around. The only problem is that my home PC doesn't seem to like reprogramming the Touchstream. I'll see how I go.

Max
Regular
Posts: 47
Joined: 23 May 2005, 08:43
Location: Bucks, UK
Contact:

Re: same problem here

Post by Max »

Fixed it!

I made sure the tap action for the left handed gesture was set to 'Hold punctpad on'. That seems to have done the trick!

Max
Max wrote:Update, still can't get the programmers' pad to work on the QWERTZ model. I have tried playing with various options. Perhaps I need to reset it and start again.

Out of interest, if anyone has a DVORAK touchstream who wants to swap for a QWERTZ, I may be interested. I'm not doing too well switching between the two.
Max wrote:Thank you for the interesting observations. It does indeed look like some settings may be overriding the programmers' pad setting. Perhaps it is time to do some more playing around. The only problem is that my home PC doesn't seem to like reprogramming the Touchstream. I'll see how I go.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests