Upgrading the forum software failed

Discuss, suggest and complain about the forum itself here.

Moderator: The00Dustin

Post Reply
User avatar
TorbenGB
Site Admin
Posts: 536
Joined: 26 Apr 2005, 00:07
Location: Vienna, Austria
Contact:

Upgrading the forum software failed

Post by TorbenGB »

Just an update on my efforts:

Some of you may have noticed that the forum has been down for the last 2 hours. I was trying to install a new version (3.0.6 as opposed to the current 2.0.2) because the new version allows much better anti-spam measures (and has many other advantages as well).

Unfortunately the new installation failed on the step that imports the old forum into the new version. Obviously the new version is no fun if we lose all our existing content, so for now I've just restored the familiar old version. (Aren't you glad that I made a backup?)

For lack of time, I am going to leave the old version running again. I hope to find a few hours some other day where I can dig into the question of why the import failed. That needs to be addressed before we can move on.
TorbenGB - webmaster & forum admin

User avatar
ivanw
Zealot
Posts: 390
Joined: 29 Jul 2005, 12:32
Location: Paris, France
Contact:

Post by ivanw »

Hi Torben,

We are with you in your effort to keep us happy with our sanctuary...

This note, just for you to know that, whatever comes out from this hard work, it will be appreciated.

Terrorism is the new deal for our species, it takes less effort to piss-off people than to please them. Now you still can give up and choose the dark side. But it would be a shame after all these years ;)

User avatar
TorbenGB
Site Admin
Posts: 536
Joined: 26 Apr 2005, 00:07
Location: Vienna, Austria
Contact:

Post by TorbenGB »

Hey, giving up is not the same as turning to the dark side! Selling the member data to spammers, now that would be evil. But you know I won't ever do that.

FabioZ
Hang-around
Posts: 4
Joined: 20 Jan 2010, 20:21
Contact:

Post by FabioZ »

Ayap! but it seems we lost all the datas anyways... when you click on any "old" topic it just says "no posts"... :cry:

EDIT: not on all topics, sorry!

User avatar
TorbenGB
Site Admin
Posts: 536
Joined: 26 Apr 2005, 00:07
Location: Vienna, Austria
Contact:

Post by TorbenGB »

True, sadly. It's not the database but likely an index that has not been rebuilt. Perhaps another restore operation will bring it back, but I'm not in a situation to spend lots of time with this.

Things are broken and I won't be able to fix them soon -- that's not satisfactory but then I've been looking for someone to replace me at this for the past two years :(
TorbenGB - webmaster & forum admin

FabioZ
Hang-around
Posts: 4
Joined: 20 Jan 2010, 20:21
Contact:

Post by FabioZ »

no one is blaming u m8.. time flies! thank you so much for the work in any case.
better broken than dead! ^_^

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests