Page 1 of 1

Could cold have damaged my unit?

Posted: 22 Dec 2006, 15:14
by ccompbell107
I just bought an advertised touchstream on EBay. The seller said it was in perfect condition and the computer would recognize it right away. I already had the multitouch utility installed and it does not recognize a fingerworks device. If fact, I get a keyboard error when I boot up. It was packed well. It was several days in transit and in below 32 degree weather. Any ideas if the cold could have damaged it? The seller has not responded to my last email and I am worried I might not be able to get the $450 back.

Posted: 22 Dec 2006, 15:51
by ivanw
suejester45 said he could fix a similar problem here

If you don't have read yet all of the many messages talking about bad sensors issues in this troubleshooting topic, I suggest you do , some solutions may apply. There are also some detailed information you can get from there too.

Anyway let us know about your progress, those who had this kind of problem may suggest more precise actions based on the details you can provide.

Posted: 22 Dec 2006, 16:08
by ccompbell107
The board seems to be completely dead. If the seller refuses to give me my money back, I might try opening it, but $450 really has set me back financially. However, I was hoping to find out if he might have shipped it in working condition and the cold weather might have affected it. It will be his word against mine that it was working. Since he already has the money, I may be left with this keyboard. Is it too much to hope that he is an honorable man?
Otherwise there is an engineering firm where I can go and have it tested and at least find out if there is any voltage on the power busses. I have printed this discussion about the repair tactics.

Posted: 22 Dec 2006, 16:20
by ivanw
jwr did just that with good results!

The problem is about finding which part of an array is malfunctioning, meaning that it is not as difficult as it would be with some single damaged part you can compare to a working one only if you have a spare unit to work with.

You should give people who can help the time to read your messages to this forum before making a decision...

Thank you Ivan

Posted: 22 Dec 2006, 17:24
by ccompbell107
Thank you and I will give others time to respond. In the meantime, I did hear from the seller and he has asked me to test it on another machine which I will do. He has agreed to have me mail back to him if it still doesn't work. He would then test it and if it is still not functional, he would return the money. He sounds like a man of his word.

Posted: 22 Dec 2006, 17:32
by thenn
Before taking apart your TS, might I suggest something. Since the TS is dead try jump staring it, might work. When you are in the Utility try this:

"I have replicated my problem. If the TS is getting a geture set update, and you unplug during the transfer, the TS will not work on any computer. Resetting via the 5x palm trick does not work either. Windows does not find any new hardware when I connect the TS on any of my 6 USB ports.

Using the fingerworks utility (Device firmware upgrade) my ts is found in the drop down box. I used apply default upgrade for this product. Pressed start, let windows install the new driver for the TS, now it works. My initial problem was that like you I had a spark of electricity hit my TS when I sat down to use my comuter. I just recreated my problem by disconnecting the ts before the gesture set could be updated."

My thought is to disconnect your when you try to upload a gesture set, then to reinstall the original firm.

Why not try, what could it hurt.
BTW, I leave a igesture numpad in my car every night. I live in PA, cold does not affect the unit on my end.

No luck

Posted: 22 Dec 2006, 18:54
by ccompbell107
The utility doesn't even find the device. Thanks for the suggestion though.