Spread 2 Fingertips tap registering when hold is being used

Comments specifically about gestures and mouse actions - on any FW product.

Moderator: The00Dustin

Spread 2 Fingertips tap registering when hold is being used

Postby lee griggs » 09 Jan 2007, 12:35

Hi Ivan, I am having problems with Spread 2 Fingertips.

When I use the hold gesture it usually activates the tap gesture as well.

Have you encountered this problem?

Can I send you my current gesture file?

cheers,
lee
lee griggs
Smarty Pants
 
Posts: 79
Joined: 21 Aug 2005, 20:49

Re: Spread 2 Fingertips tap registering when hold is being u

Postby ivanw » 09 Jan 2007, 13:43

lee griggs wrote:Can I send you my current gesture file?

It would be the best thing to do!
User avatar
ivanw
Zealot
 
Posts: 390
Joined: 29 Jul 2005, 12:32
Location: Paris, France

Postby The00Dustin » 09 Jan 2007, 22:13

This sounds familiar to me, though it might have been the tap action being used (along with the slide action) when a slide was issued. Either way, it was a long time ago on the old forum, so you might want to search there to see what people discovered (wasn't my issue, though I was able to replicate it, but I really don't remember what came of it).
Dustin
The00Dustin
Grizzled Veteran
 
Posts: 182
Joined: 28 Apr 2005, 22:07

Postby ivanw » 10 Jan 2007, 16:20

There is a difference between your configuration file and mine:

I have such a combination working as expected that has a "Minimum Hold Time" of 350ms where yours has only 125ms.

You may check with a higher value there because such a short time qualifies even for a tap.

  • Thumb+Pimky (L Spread)
  • Hold PunctPad On
  • ChordHold Properties tab
    Minimum Hold Time = 125
User avatar
ivanw
Zealot
 
Posts: 390
Joined: 29 Jul 2005, 12:32
Location: Paris, France

Postby lee griggs » 13 Jan 2007, 12:53

Thats strange, Ive just checked mine and it says 300ms. Maybe it is not registering as 300? It feels like 300....
lee griggs
Smarty Pants
 
Posts: 79
Joined: 21 Aug 2005, 20:49

Postby ivanw » 13 Jan 2007, 16:32

As this is what i can read from your configuration file, I think we are not talking about the same gesture.

I wanted to quote the relevant xml lines but we have a bug in our current version of phpBB that makes it impossible. (portions with "lower" and "greater" symbols are swallowed).
User avatar
ivanw
Zealot
 
Posts: 390
Joined: 29 Jul 2005, 12:32
Location: Paris, France

Postby lee griggs » 15 Jan 2007, 12:18

As this is what i can read from your configuration file, I think we are not talking about the same gesture.


ah yes. It looks like the chord I am talking about is called:

Word Transpose

Its near the bottom of the gesture editor for the right hand.
lee griggs
Smarty Pants
 
Posts: 79
Joined: 21 Aug 2005, 20:49

Postby ivanw » 15 Jan 2007, 13:50

OK, not a timing problem then.

At this point, the only difference between this gesture and another that works is a missing ChordLift.

Maybe a ChordHold and a Synctap cannot coexist unless a ChordLift is well defined and handled. Unless you've already checked that, a ChordLift with an Empty action may do the trick.

Also, any uneventful action could replace the Empty action if this one does not make it any better.
User avatar
ivanw
Zealot
 
Posts: 390
Joined: 29 Jul 2005, 12:32
Location: Paris, France


Return to Mousing and Gesturing

Who is online

Users browsing this forum: No registered users and 2 guests

cron