Page 1 of 1

Left half Lagging and problems

Posted: 27 Feb 2007, 04:09
by Timwillhack
Hey guys, I just lucked out (hopefully) and got a lp on ebay for $590 (BIN) (sarcastic yay)

I have received it and unfortunately the left half seems to be 'lagging'. If I hit say 'a' it types the a in about 1/3 of a second, then even after I lift my finger, it types a whole bunch of them. I've tried the 5 palm reset thing, and the diagnostics say its perfect! Also if I hit backspace sometimes it picks it up fine, others it doesn't register. Sometimes it will just go crazy deleting even after I take my hands off the keyboard. Currently I would say it is useless if i don't fix this (no consistency) and I'm new to it, so it would be impossible to even try to train myself to use it!

I've been dying forever to get my hands on one of these as I'm having RSI problems and I'm a programmer. I would love to be able to keep this and fix it, and not have to send it back.

Any suggestions?

Posted: 27 Feb 2007, 04:59
by ken gray
is this happening on all the keys on that side?
what about gestures on the left side; are they all slow too?

you may need to load a "clean" configuration as there is NO way to find out what is in the keyboard now. I can't think of a way to do that specifically but since you can run diagnostics you can get into the editor and just save the default config and load it onto your keyboard. it'll overwrite whatever is in there and hopefully clean it up.

since the dx is clean, i don't think you jammed up with this one; i think it's just a matter of resetting it to factory default config.

Strange LP behavior

Posted: 27 Feb 2007, 05:40
by Minox
I would be willing to look at it - if it is fixed after I check it out I would ask a small fee to cover my time. Otherwise, I will return it to you as it was sent to me with no service charge.

Posted: 27 Feb 2007, 16:42
by -jeffB
Doesn't this sound a bit like the "cell-phone interference" problems some users have reported? Static or external interference would be my first guess, particularly if the board passes diagnostics.

Posted: 28 Feb 2007, 04:33
by Timwillhack
Minox, How much would you be charging to take a look?

I haven't used one of these keyboards before, so I haven't really even played with the gestures (which is one of the reasons I bought it)

I'll be able to play with it tomorrow, and I'll be able to post more info.

one thing that concerns me is that the right side is the one with the connection to the computer. I would think considering it is working just intermittent that maybe there is a problem with the center connector, however the repetition after I lift my hand makes me think otherwise, because if the chip on the left board is sending the data, if there was a problem with the center connector, it wouldn't be slow but it just wouldn't show up (I'm making an educated guess here!)

Thanks for the quick feedback though guys!

Posted: 28 Feb 2007, 17:43
by Timwillhack
Ok so I've been playing with it. I tried putting mousing on the left side, and it works, but its a little sporatic, almost like the surface isn't seated properly or something, its like it thinks by having one finger down that its in mouse mode. I do have very sweaty hands, but the right side is perfectly fine, and the left is still acting up. I have tried gestures on the left and they work, its just somewhat sporatic and delayed a bit. Its definately unusable at this point, especially for someone who is trying to train themselves on it for the first time.

I gotta say I wish I worked perfect, because I'm already loving the cut/paste, line positioning / mousing on one surface. Dang it!

I should also mention that I've now tried it on 3 computers, all of which are doing the exact same thing. (and one of the computers was literally an hours drive away from these 2)

I would also like to point out that it seems that when I initially make a change on the utilities and 'try' it works fine for literally 5 or so seconds after I start typing. Then goes into 'dumb' mode.

Any help is vastly appreciated. Its literally been my dream now to get my hands on one of these. Never thought I ever would seeing how high the prices have been.

I also want to point out that I disabled repeat rate, and langauge spelling model and backspace autocorrect, still same thing.

Posted: 28 Feb 2007, 17:46
by ken gray
did you load a new/default config?

Posted: 28 Feb 2007, 17:50
by Timwillhack
doesn't it do that when I upgrade firmware? I did the upgrade firmware thing to 1.6 (which it already was but went through with it)

Posted: 28 Feb 2007, 17:51
by ken gray
no, i dont think it does.

Posted: 28 Feb 2007, 17:54
by Timwillhack
well i've done 'Restore Defaults' from the 'Feature Selector" and hit 'Try'


Now I did it in "MyGesture Editor" went to file "Restore Factory Defaults", hit yes, then "Transfer to Device"

Still the same way.

Posted: 28 Feb 2007, 18:03
by ken gray
have you tried moving that cable around during the diagnosis to see if that can affect it?

Posted: 28 Feb 2007, 18:07
by Timwillhack
How long is the diag supposed to take, I'd say its about 2 seconds from when I hit the "RUN diag" button


Reading diagnostics...

Diagnostic Report for TouchStream ST/LP ver 1.6:
All sensor array tests PASSED!
Loaded 1243 Key/Gesture Mappings SUCCESFULLY
Keymatrix#: 34
Testing Complete.

Posted: 28 Feb 2007, 18:09
by ken gray
yeah, about that long.
you may need to crack it open and take a look (note: unplug first).

Posted: 28 Feb 2007, 18:16
by Timwillhack
Hi Ken, Thanks for the quick responses.

How do I do that, Do I have to 'exacto cut near the connectors' or is there another way to just look at the top surface?


Posted: 28 Feb 2007, 18:19
by ken gray
i'm not sure but you can do a search here for replacing or extending the cable; some folks have put in longer cables and i think FW actually gave out instructions on how to due it but voided the warranty 80)


Posted: 28 Feb 2007, 19:04
by Minox
Don't open it yet....

First let me tel you that opening it is not usually needed. It sounds like the surface has interference. Have you cleaned the surface with a rag sprayed with Lysol cleaner? DO NOT spray the device directly, only spray the cloth and wipe the device.

Opening the unit should always be the lat resort. There are little clips all the way around the bottom. These clips are very easy to break. I've taken apart several units and only managed to open 2 that no tabs broke on. Also there is glue where the cable exits the housing.

It sounds like someone spilled a drink on it and since they couldn't get it working right they sold it on ebay and since the sensors don't complain they prob figured they wouldn't get found out.

Clean the surface, let it dry, try again... let us know what happens.

Posted: 28 Feb 2007, 19:33
by thenn
Hey I got a numpad I have the same issue. Turns out its the USB cable or something internal(I think). Since I opened my numpad my USB cable has exposed silver ground wiring.
To tell you the truth I have ridiculous amounts of static at my house. My mouseing gets interrupted and gets all crazy when I just try to mouse. Kind of like there is a roller ball mouse, that has the ball stuck. Then it will just stop working(sometimes). What I did was flatten my hand on the pad to ground(you will see the arrow do a little circle), then I tap my fingertips on the thing(just the tips). For some reason this works for me. But as I said before, try at your own risk.

Also, I've opened my numpad casing, and it's pretty tough trying not to cut the little tab that has been glued down around the cable. Turns out if you do cut the tabs, a little scotch tape goes a long way. I have tape around the whole thing.

My friend actually stole the numpad from me, but I got it back by taking his monitor.

Yes, I have the ghetto fabulous igesture.
Trying to wear it out so I can take my other igesture back from my wife, unfortunately/fortunately it won't break all the way:)

Posted: 28 Feb 2007, 21:31
by Timwillhack
What else can I clean it with. I was going to try rubbing alcohol is that ok?

I don't think I have lysol

How bout windex?


Posted: 28 Feb 2007, 21:32
by ken gray
i think windex is ok....remember the surface is just a sticker.

spray it on the cloth the rub down the kb....note:unplug first.

Posted: 28 Feb 2007, 21:42
by Timwillhack
i just wanted to let you guys know that before I even cleaned it all of a sudden it was working fine and I was typing in notepad to train a bit. Once I started thinking about it and was happy I must have got nervous and my hands started to sweat - a lot. They get really hot too. Could that be any part of why this would happen? The only reason I wuold think this would be false is because its only the left side!

I'm going to try windex

Thanks again!


I have tried the windex and it worked again for a little while. Tried it on another computer, as I don't want it to just be intermittantly working. It worked once again for a little while and now its back to how it was before.

Bah, it seems as though I'm heading on down the road of returning it.....

Posted: 06 Mar 2007, 16:04
by Timwillhack
Its gotta be an intermittent connection somewhere. Too bad I don't have the cash to afford to play with it.