Page 1 of 1

device is dead, only lasted 8 years!

PostPosted: 13 Sep 2014, 05:28
by thenn
Though I mourn the death of my trusty device. I cannot say it wasn't my fault. USB was problematic so I decided to solder a new one on. With a crappy soldering iron. Four hours later, windows cannot install the device.

It was a good run.
Looking for a replacement or cheap parts.

I burn the little thingy next to my middle finger in the pic.

You're thinking how the heck did that happen, mistake in judgment, nuff said.

Re: device is dead, only lasted 8 years!

PostPosted: 13 Sep 2014, 11:04
by The00Dustin
Ugh! Sorry to hear about that. It looks like it could be a standard component that you might be able to get from a local electronics store or order from digikey. Unfortunately, it would have been easier to tell what it is before it got burnt, but if you can tell, that would be the cheapest thing to try first. If you can't, maybe there are some other pictures of disassembled devices, or maybe someone else who had to fix their USB cable can tell you what it was. As you can easily see, there isn't much traffic on this forum anymore, but hopefully you'll get some kind of help with a bit of patience.

Re: device is dead, only lasted 8 years!

PostPosted: 13 Sep 2014, 14:03
by thenn
Thanks for the advice.
I'm going to try replacing the control board with one for a broken device. We'll see if that wakes it up.

Re: device is dead, only lasted 8 years!

PostPosted: 18 Sep 2014, 07:49
by TorbenGB
As much as I hate to say this, our devices have become very cheap on Ebay these days. They used to sell for many, many hundreds of dollars (even as high as $2000!) but no longer.
So if all else fails, you can probably get a "fairly cheap" replacement from Ebay. Or check in our marketplace forum. Or ask me; I have a spare device that I haven't decided on selling yet.

Re: device is dead, only lasted 8 years!

PostPosted: 28 Sep 2014, 20:50
by thenn
Update, fixed again. Just needed a xp PC to get the thing working.