Page 1 of 1

TouchStream kinda flaky with my new PC

Posted: 11 Jan 2006, 15:45
by goadeff
I've built a new PC with a FoxConn NF4K8AC-RS-1.0 motherboard, and my TouchStream seemed to work OK, but then I noticed the four-finger scrolling of web pages and other content was slow, and my PC would beep at me at times, as if it couldn't keep up with the scrolling... I installed the FingerWorks utilities, and was greeted by a flurry of the Windows "device connected/disconnected" bleeps, then the FingerWorks utilities would complain that it couldn't find a device connected!

I've tried setting my mobo USB to v1.1 only, instead of 1.1+2.0, I've tried other USB ports... all the chipset and other driver software seems properly installed...

Any ideas?

Posted: 11 Jan 2006, 20:45
by ivanw
Many things have been said about this on the Fingerworks Support Forums. You should go to this search page and enter DFU in the Search By Keyword field. You will get information about this Device Firmware Upgrade clumsy mode.

If you don't find the solution to your problem, you can look near the System Properties->Hardware->Device Manager. You should see something about your device near the Hman Iinterface Device or the Universal Serial Bus controllers at the bottom of the tree.

In case of despair, before looking for Valium. come back here and tell us what's going on...

It works... I guess...

Posted: 12 Jan 2006, 14:37
by goadeff
Well, I set motherboard USB to v1.1 rather than 1.1+2.0, removed all traces of TouchStream from device manager, and reinstalled. The keyboard seems to work better now. I still get the beeping 4-fingered scroll as described before, and the FingerWorks utilities work but operations are extremely slow. Flashing the keyboard BIOS or transfering settings takes forever! I verified keyboard and utilities worked perfectly on another computer; I was starting to sweat thinking my difficult-to-replace ergonomic hardware was failing. Could an insufficient power supply cause these symptoms, or would I first get a pop-up warning about power usage from the USB controller? I'm using an older 250W 20-pin pwr supply and motherboard is 24-pin (but manual says 20-pin will work, just align it to one side of the mobo socket. It strongly recommends a 24-pin supply only when using one of the Express PCI slots. I will likely next try a bigger 24-pin power supply...

Re: It works... I guess...

Posted: 12 Jan 2006, 15:33
by ivanw
goadeff wrote:(...) I verified keyboard and utilities worked perfectly on another computer. (...)
Now you have your answer :!:

I had a whole bunch of jokes from my previous Asus motherboard USB with my TouchStream. Then I plugged it into an extension card USB and everything went fine. I have a new Asus P5WD2 motherboard that does not have this issue. So, unless the TS needs more than its nominal 150mA under DFU mode operation, it is unlikely that the power supply may be involved here.

Conclusion, you have USB and almost-USB. We must only use the first kind :wink: