malfunctioning

Comments specifically about the keyboard devices.

Moderator: The00Dustin

Post Reply
shosolosa
Hang-around
Posts: 4
Joined: 27 Jun 2005, 08:35
Contact:

malfunctioning

Post by shosolosa »

Could anybody help with this?

On the left side of my TS some of the keys don't work since yesterday. The "MultiTouch System Diagnostics" reports that 320 sensors are malfunctioning on the left side.

:?:

User avatar
TorbenGB
Site Admin
Posts: 535
Joined: 26 Apr 2005, 00:07
Location: Vienna, Austria
Contact:

Post by TorbenGB »

To the untrained ear (mine) it sounds like the ribbon cable is coming loose. Either you can fix it with luck, by wiggling the cable a bit to put it back in place, or you need to consider fixing it for real, which is not that easy now that the FW support can't be counted on.

Look in this forum -- there's another thread about that ribbon cable where a user successfully replaced his broken cable with a new one. That's what you need to consider, too. But I'm wishing for you that just wiggling it a bit might fix it -- for a while.

And don't transport the TSLP again unless you really really need to. With these trouble reports we've heard in the forums lately, combined with the end of true tech support, I've decided to not move mine again unless I need to -- simply to protect the ribbon cable from wear and tear. That ribbon cable is the only soft spot in the product, when looking at everyday use.

Max
Regular
Posts: 47
Joined: 23 May 2005, 08:43
Location: Bucks, UK
Contact:

Re: malfunctioning

Post by Max »

shosolosa wrote:Could anybody help with this?

On the left side of my TS some of the keys don't work since yesterday. The "MultiTouch System Diagnostics" reports that 320 sensors are malfunctioning on the left side.

:?:
shosolosa, I had this problem and as Torben said, I managed to fix it myself by replacing the ribbon cable that connects both sides. If the problem is intermittent then try adjusting the ribbon cable and don't move the keyboard any more. If you can't get it back working again then you will need to buy a replacement cable from Digikeys. Search the forum for more info.

Ah, here it is: see my post "Left side of Touchstream LP is dead" in this section of the forum.

Max

shosolosa
Hang-around
Posts: 4
Joined: 27 Jun 2005, 08:35
Contact:

Post by shosolosa »

Thank you very much for your help!! :)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest