Page 1 of 1

Upgrading the forum software failed

PostPosted: 02 Feb 2010, 20:53
by TorbenGB
Just an update on my efforts:

Some of you may have noticed that the forum has been down for the last 2 hours. I was trying to install a new version (3.0.6 as opposed to the current 2.0.2) because the new version allows much better anti-spam measures (and has many other advantages as well).

Unfortunately the new installation failed on the step that imports the old forum into the new version. Obviously the new version is no fun if we lose all our existing content, so for now I've just restored the familiar old version. (Aren't you glad that I made a backup?)

For lack of time, I am going to leave the old version running again. I hope to find a few hours some other day where I can dig into the question of why the import failed. That needs to be addressed before we can move on.

PostPosted: 03 Feb 2010, 03:18
by ivanw
Hi Torben,

We are with you in your effort to keep us happy with our sanctuary...

This note, just for you to know that, whatever comes out from this hard work, it will be appreciated.

Terrorism is the new deal for our species, it takes less effort to piss-off people than to please them. Now you still can give up and choose the dark side. But it would be a shame after all these years ;)

PostPosted: 03 Feb 2010, 10:19
by TorbenGB
Hey, giving up is not the same as turning to the dark side! Selling the member data to spammers, now that would be evil. But you know I won't ever do that.

PostPosted: 13 Feb 2010, 19:32
by FabioZ
Ayap! but it seems we lost all the datas anyways... when you click on any "old" topic it just says "no posts"... :cry:

EDIT: not on all topics, sorry!

PostPosted: 13 Feb 2010, 22:04
by TorbenGB
True, sadly. It's not the database but likely an index that has not been rebuilt. Perhaps another restore operation will bring it back, but I'm not in a situation to spend lots of time with this.

Things are broken and I won't be able to fix them soon -- that's not satisfactory but then I've been looking for someone to replace me at this for the past two years :(

PostPosted: 14 Feb 2010, 01:01
by FabioZ
no one is blaming u m8.. time flies! thank you so much for the work in any case.
better broken than dead! ^_^